Game Plan Pinball

Home
Forum
Search
Machines
History
Parts
Repair
Flyers
Roms
Contact Us
Manuals & Schematics


Also Check Out
PinballShark.com
ATVFlorida.com
© 2014

Welcome to GamePlanPinball.com

Welcome, Guest. Please login or register.
October 22, 2019, 03:07:41 AM
Home Help Search Login Register


+  GamePlanPinball.com Forums
|-+  General
| |-+  Tech Corner
| | |-+  I can't get the 7th flash.
« previous next »
Pages: [1] Print
Author Topic: I can't get the 7th flash.  (Read 3579 times)
doberman
Newbie
*
Offline Offline

Posts: 2


View Profile
« on: June 13, 2013, 10:06:53 PM »

I have a Stern Stars machine which was working great. I put in a new bumper assesmbly and didn't realize that the diode was reverse of my original and damaged my driver board. So I replaced the diode and placed it band side to the power. But now I can't get the machine to boot up. I put in a new rectifier board and replaced the connectors. I put in an Altek MPU and Altek SDB from another machine and only get 6 flashes. The flippers work and I have my 43V in all coils. I even repinned J1 on the MPU. What is going on? What should I do now?
Logged
doberman
Newbie
*
Offline Offline

Posts: 2


View Profile
« Reply #1 on: June 13, 2013, 10:17:35 PM »

The flippers work, and all the coils have 43v going to them. Having put a new Alltek MPU and Driver board and new rectifier board and new connectors for the rectifier board. The only thing I can think to do know is replace all connectors to the MPU and driver board. Anyone got any ideas?
Logged
Pinball Shark
Administrator
Jr. Member
*****
Offline Offline

Posts: 94



View Profile WWW
« Reply #2 on: June 15, 2013, 10:38:08 AM »

You know this is a Game Plan forum right?  wink  No matter, we hardly get any posts any way.

Whenever I work on a Bally/Stern, the FIRST thing I always replace is all the power supply connectors (which you did) AND all the connector pins in J3 on the SDU, AND J4 on the MPU.

The J1 you replaced on the MPU is for the displays. The other two connectors are for switch inputs. All it needs to boot is J4.

If all those connectors are good and the power supply is good, you have a bad MPU.

Here's specific info the 7th flash: http://www.pinwiki.com/wiki/index.php?title=Bally/Stern#Seventh_flash:
Logged

Pages: [1] Print 
« previous next »
Jump to:  


Login with username, password and session length

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!